Using ableton to sequence patterning 2


#1

Sorry if this is absurd or obvious or whathaveyou but I put Patterning down for a year and am trying to dial it back into my workflow. I’m trying to use Ableton to sequence Patterning 2. I’ve got it running through Studiomux on my ipad. I have it figured out so that I can play the pads on Patterning and record the midi directly into Ableton, but when i play it back via Ableton there is no sound. I can’t bear another session wasted trying to wrap my brain around this so any help would be much appreciated. Thanks!


#2

Since it sounds like you are getting things recorded into Ableton, could you post a screen shot of your Ableton track I/O so I can see how things are routed?


#3

Thanks for the reply :slight_smile: Here’s a screenshot of Live. I’ve got it setup through track 13. I’m just running the midi through my Scarlet. I think i had the input set to Patterning 2 when i was recording from Patterning into Ableton…Anyway, I’m frankensteining this whole operation through a bunch of things that I don’t fully understand.

48%20PM


#4

I can’t imagine that this isn’t already in your documentation somewhere, so if you can just point me in the right direction…


#5

It’s hard to see exactly the settings from here. But I think the issue is that you are recording the MIDI into Ableton, but you are not sending it back to Patterning to play the sounds.

When you record them you are actually triggering the internal sounds as triggered by the pads, so that’s why you hear it when you record. But for it to play back from ableton, you need to route the output of your MIDI track back to Patterning to trigger it.

So, route the output of your MIDI track to Patterning’s input. Then, set up the MIDI input to Patterning using MIDI Learn or with the “Generate Default MIDI Input” MIDI button on the RECORD page. One thing worth noting – when you generate the default MIDI input mappings, it uses the white keys notes starting at MIDI C as the mapping in. That should line up correctly with Patterning’s MIDI outputs, if you didn’t edit them. But if you did change the note outputs for Patterning MIDI tracks, they could be different values.

Hope that helps?


#6

Cool, thanks for the help. I was able to get it working correctly. I had to use 2 tracks, the second simply functioning as an external instrument that was sending the midi back to patterning. It’s still not perfect, as the midi is somehow triggering my other external instrument track and causing my Moog to make some very odd sounds…but that’s got nothing to do with Patterning.

Appreciate the responses.