Resolved : Patterning 2 won't open

I just downloaded the app. I’m only shown the start screen for a split second, and then it crashes out of nowhere. I’m using an iPad Mini 2 running iOS 12.5.7. I’ve tried every tangible technique (deleting and redownloading, restarting my device, etc) and I still have the same issue. I’m certain it isn’t the device itself because other apps I’ve downloaded have worked. Can someone please help?

Hey - thanks for the report and sorry about the crash. I will look at the crash logs and see what’s happening.

Have you figured it out? No pressure at all. If not, do you think it would be possible for me to use an earlier version of the app? Thank you so much

I haven’t figured it out yet, but i suspect the latest update accidentally made iOS 12 incompatible.

I just looked to see if I can give you access to the older version, but the testflight build is expired and I can’t fix that from where I’m at.

I will get it sorted on Monday when I get back to my office. Thanks for your patience!

Totally, I appreciate your help

I can’t track down your crashes. Can you see if there’s a log on your device? To locate and email crash reports for iOS, iPadOS, watchOS, and tvOS apps:

  1. Open the Analytics & Improvements section of Settings on the device. See Share analytics, diagnostics, and usage information with Apple.
  2. Tap Analytics Data.
  3. Locate the log for your app. The log name starts with <Patterning>_<DateTime> for crash reports, or JetsamEvent_<DateTime> for high-memory use crashes.
  4. Select the desired log.
  5. Tap the Share icon, and select Mail to send the crash report as a mail attachment.

Gotcha. I found the logs and forgot to enable data sharing, you may or may not be able to see it now, I’m unsure. I can’t seem to email it so here’s a link to one of the .ips logs just to be safe. (I don’t know whether or not this should be posted here, so I apologize if I’m not doing this right)

thanks - I just dug up an iPad that has 12.5.7 on it and was able to reproduce the error that matches the file you just shared. hopefully I can sort it out quickly!

Awesome, thanks for letting me know

got it! In case you’re curious – it’s an apple bug involving swiftUI, which I’m not even using, but whatever! swift - dyld: Library not loaded SwiftUI when app runs on iOS 12 using @available(iOS 13.0, *) - Stack Overflow

will try to get this submitted today.

It’s up on the App Store now - if not just wait a couple hours and try again.

It works perfectly! So psyched to finally try this. I can’t thank you enough

1 Like