Patterning iPhone: Midi Out Note Randomly


#1

Hi,

I’m setting midi note out of 1 track (kick track) from Patterning iPhone via Network session (wifi) to other app which receives a specific note to trigger an action but Patterning sent a bunch of random notes rather a specific note that I set in Midi tab. I’ve tried to change all the Note options in the “Pencil” tab but no luck.

Have anyone experienced same issue? Any advice would be great.

Thanks


#2

Can you check that you don’t have any layer automation written on the “MIDI Note” or “MIDI Note Transpose” Layers?
IMG_482D48DCD8C6-1


#3

If that’s not it, let me know the name of the drum kit you are using… it’s possible that the drum kit actually has randomization settings on it… which aren’t editable on the phone version :grimacing:


#4

Hi Ben,
Thanks for your reply.

As I mentioned earlier, I have made change back and forth in those layers “Midi note” and “Midi transpose”, also created new default pattern but that issue still occurs…

it still randomizes in different drum kits, please see screenshots attached.

Any idea?

PS: I only can upload 1 image in my post :frowning:
so sorry for multiple replies :expressionless:

Best
10%20PM


#5

Midi note out for track 1
IMG_0005


#6

Drum kits
IMG_0007


#7

IMG_0006


#8

IMG_0008


#9

IMG_0009


#10

IMG_0010


#11

Hi Ben,

Any update on this?


#12

I haven’t been able to reproduce the issue, so I’m not sure what’s going on. When you send MIDI using that single kick drum pattern, what happens? The Ableton screen shot you shared has a lot more going on in it. Let’s try to simplify as much as possible to sort it out.


#13

That’s the only one track kick drum pattern which i set midi note C3 to be sent out.
I then programed to receive that one C3 note to trigger an action but those notes are what other software being received rather the specific C3 note. That is the issue.
I used Ableton just to visualize / capture that issue.
I noticed that the clock quantization is fine


#14

That’s quite confusing, because the MIDI being received is a totally different rhythm, and with chords being played - which is something Patterning can’t do. Is there anything else between Patterning and the MIDI track? A plug in? Is there anything else sending MIDI at the same time?


#15

Oh sorry i know why you get confused
It actually sends one note a time, i overdubbed them in the same track that’s why it confuses you :laughing:


#16

Ok, can you try recording again, just a single note, no overdubs, so I can see what happens?


#17

Sure, here you goimage


#18

This is so strange - it’s apparently only an issue using Network MIDI, since it works correctly (for me) when sending to other apps, and also with the exported MIDI to Ableton Live Set. I’ll have to dig in an see why. If you happen to have another way to get MIDI out of your phone and to the computer, try that and see if it works.


#19

I did try to send midi through USB and have the same issue