Issue when exporting odd time signatures in Patterning2


I encountered a problem when exporting odd time signatures. I have tried exporting a 5/8 drum pattern, and regardless of how I export it (audio clip or Ableton session) the files are exported as 4/4. What Patterning2 seems to be doing is adding a section to complete a 4/4 beat. Hence when I export the 5/8 clip it adds the 3 initial beats to that file, thus rendering two 4/4 clips (or something like an 8/8 clip). I posted this question in the Audiobus forum but I the solution I had would be too time consuming. This is the link to that post were I also posted some images to better explain the problem.

question in audiobus forum


When you export, make sure to set the length of the exported file correctly. I will use the “song” time signature, from the FILE screen to determine how long a measure is.

If you are exporting each track individually, it should automatically record one loop to the length of the loop, regardless of the time signature.

If you want to share a screen shot of your FILE screen’s time signature and the export settings you are using, I can hopefully help!

Sorry I just checked the audiobus forum link. I see the song setting is correct, but please share the export screen settings so I can verify how it’s being exported. Thanks! (and sorry for not responding earlier!)

Thanks for the reply,
I took these export pictures:

Any of those export options gives me the same behavior (first 3 bars repeated). The worse one though is the Audio/Clip option, as that one also adds the first beats as the other ones but none of the beats fall into place (so with that option it would be a matter of not only deleting the extra bars but having to warp the beats.

Hope this helps!

EDIT: I got a “new users can only post one picture”. I will see if I can add the other pictures in a subsequent reply

Second picture


Another export option

Third and worse export option for my 5/8 example:


I just looked again at your audiobus post.

Change your loop mode from “DIVIDE” to “STANDARD”

“DIVIDE” mode divides a single measure into “steps” numbers of steps (10 in your case). What you want is STANDARD mode, so that you can have 10 x 16th notes steps for 5/8 time.

Thanks! that worked perfectly.
Congrats on the app, hands down my favorite one (and I have used many!)

Ah, great! So glad that is getting you the correct results. Thanks for your patience!