Sending Network MIDI to an Ableton Drum Rack

Hello! First off, I want to say I love Patterning, it’s really a special creation. I’ve used it for a long time with my own samples, but never taken it over to the Ableton side with MIDI. I’m trying to do that with network MIDI and I must be missing an obvious setting because I’m getting no MIDI indication in Ableton. I’ve played around with a lot of settings.

I’ve also tried it via idam and it’s not working either, so it must be a setting in Patterning? I am able to send MIDI with other apps via network MIDI and also idam and getting response on those Ableton channels. Can anyone see what’s not switched on, or improper?

The forum won’t let me upload multiple pics, so I stitched these together, hopefully it formats large enough to see:


Oh man, I just spent like a half hour composing that and then saw the other MIDI panel for each sound… I think that’s sorted. ha

Actually, I still have a question. I can get MIDI to send on the first three slots in Patterning - kick, snare, hat, into the appropriate slots on a drum rack. I can’t get any MIDI to send from the perc slot beyond - clap, noise, etc though. I can page through all the midi note outputs on the right side of Patterning and none of them engage MIDI in Ableton. Any ideas?

IMG_0229 2

I’m glad you found the MIDI Port selector :slight_smile:

I just tested this and wasn’t able to reproduce the problem - I can get MIDI to send over IDAM from any of the tracks in Patterning and using any note.

Are you using Drum Rack in Ableton? Are you seeing it light up anywhere on the grid?
Screen Shot 2022-12-02 at 10.38.15 AM

I will continue to think about what else can be tried out…

Hi, thanks for the response! I opened an older project and somehow it’s working and sending MIDI on all drum rack slots fine after dialing in the right note. I thought it might be something in my default set, but went back to it after and that’s working too.

For sure those last five wouldn’t send any info out (yep drum rack). There was nothing in the Ableton channel with the rack on either set. I must have an elf in there somewhere that likes to filter MIDI notes out, or something. I’d also restarted both devices last time and that didn’t help. :man_shrugging:t2:

Anyhow, thanks again for the great app. Just left a long-deserved review.

I would check the MIDI Mappings panel in Ableton and see if there’s anything in there that could be intercepting the notes? Does seem strange.

I think you’re right about it being something like that. Have a full amount of controllers in there, but only a couple were active. Will keep an eye out. Thanks again