Connecting Apps To Logic Pro

I have been using app- Patterning, Choirdon ect with Protools and Ableton. But recently switched to Logic Pro and every time I try to connect these apps it overloads my Mac with the pinwheel of death icon. Both my MacBook Pro and iPad Pro are new operating systems and have plenty of room. Walked thru it with an apple Logic tech and the apple system is working with Korg, Moog app ect. Help!

Hey @Kfc,

Can you tell me a bit more about how you have Patterning’s MIDI Out and Logic’s MIDI In configured? Are you using a MIDI Interface, wireless, bluetooth, etc? Send screen shots if possible!


Hey Ben,
I use the iPad/logic remote interface, which works for other music apps and what I normally use, it doesn’t work. It overloads freezing logic. I have tried going direct which works for your apps into pro-tools but also overloads Logic. Help!

I’m not familiar with iPad/Logic remote. If you can let me know what the configuration is, I can try to test it… otherwise I don’t know where to look.

Also, are you using any sort of clock between the two, MIDI or Link, for example? If so, I need to know how those are configured so I can test them.

Update. I just downloaded logic remote and was able to get patterning to send MIDI notes to it without any problems.

I would caution though that if you are making this connection wirelessly there will be a bunch of latency and jitter… Haven’t tried using a cable yet.

Hey Ben,
Thanks for getting back to me. I have been using a cable the whole time, I am not doing it wirelessly. So I can connect to it but it won’t record and the Mac says it’s connected and this is when I get the pinwheel. Did you record onto Logic? Can you give me the specific steps you used to connect to the iPad- logic remote-macbook. I initially was just plugging it in direct with no interface since it’s an instrument in itself on the iPad and that’s how other music apps work have worked with Logic.
thank you for your help!

I created a blank file in Logic.

Created a new midi instrument track, and record enabled it.

Opened Patterning 2 and Logic Remote.

Set the MIDI Output of a Patterning 2 track to be “Patterning”. (virtual port). Hit Play.

Open up logic remote… Unfortunately I can’t get logic remote to work in the background, so it doesn’t want to receive MIDI until I foreground Logic remote, which is irritating.

Hit record in Logic.

That’s all!

I have also tried this using Inter Device Audio MIDI, and I find it more fluid than going through the Remote app.

On your Mac, in the audio settings, Enable your iPad as an audio device – this allows it to work as a MIDI device over the cable.

Then choose “IDAM MIDI host” as your MIDI output in Patterning.

Hi Ben,
So I followed these steps and realized but when I came to 'Set the MIDI Output of a Patterning 2 track to be “Patterning”. (virtual port). Hit Play." it didn’t work. Is this the same for Patterning 1 because that’s what I am using (sorry forgot to mention).
thank you

Also screen shots would be helpful, thanks again!

Hi Kelli,

Sorry to be a broken record, but can you please send me screenshots of your set up? That is 10000x faster for me to troubleshoot than doing it this way! Thanks :slight_smile:


Of course, can you answer my question too, does it matter if I use- Patterning 1 or 2?
Screenshot 2022-01-12 at 3.01.21 PM



I also tried with a brand new empty file with no music tracks and it still didn’t work. How do I connect it in the midi section on Pattering that is what I am specifically having problems with
thanks again!

It should work with Patterning 1.

In Patterning, move to the FILE Screen, and tap the MIDI button. Show me what that screen looks like!

Are you trying to record audio or MIDI into Logic? I read this initially as MIDI, but now I see I might have been wrong?

audio :slightly_smiling_face:
Though this conversation has been making think getting a different interface. I am looking at the Focusrite Scarlet. Suggestions?